Snyk SCM Integrations Issue
Incident Report for Snyk
Resolved
Our Engineers have deployed a fix, which has proved successful.

No further impact is expected and the Snyk Incident Response has now been stood down.
Posted Aug 29, 2024 - 14:58 UTC
Update
The cause of the issue has now been identified and our Engineers are working to deploy a fix.

We will provide a further update once the fix has been implemented.
Posted Aug 29, 2024 - 14:02 UTC
Investigating
Our Engineers have identified that non-Github SCM integrations are behaving unexpectedly.

Customers may experience their non-Github SCM integrations resetting, removing all credentials after the 'save' button has been selected under Pull Requests->Automatic fix pull requests settings. As a workaround to this, customers can re-enter their credentials.

Our Engineers have confirmed no projects are lost as a result of this behaviour.

The Snyk Incident Response has been invoked and our Engineers are investigating.
Posted Aug 29, 2024 - 13:50 UTC
This incident affected: SNYK-US-01 (app.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source), SNYK-US-02 (app.us.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source), SNYK-EU-01 (app.eu.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source), and SNYK-AU-01 (app.au.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source).