Snyk CLI Upload Reporting Issue

Incident Report for Snyk

Resolved

The fix has been deployed, and our Engineers have observed no further issues.

The Snyk Incident Response has now been stood down.
Posted 6 days ago. Mar 24, 2025 - 11:39 UTC

Update

A fix has been identified; however, to prevent any further potential risk to services over the weekend, this will be deployed on Monday, March 24th.

We will keep you updated with our progress.
Posted 8 days ago. Mar 21, 2025 - 14:29 UTC

Identified

Synk Engineers have identified an issue affecting Snyk-US-02, Snyk-EU-01, and Snyk-AU-01. No impact has been observed, and there is a low expectation that this will occur. However, the potential impact occurs when new code vulnerabilities are introduced after March 19th; customers utilizing the Snyk code report (CLI Upload) may observe that previously found issues will be given new identities. As a consequence, these issues will not be ignorable. Snyk engineers are working towards mitigation.
Posted 9 days ago. Mar 20, 2025 - 16:11 UTC
This incident affected: SNYK-US-02 (app.us.snyk.io) (Snyk Code), SNYK-EU-01 (app.eu.snyk.io) (Snyk Code), and SNYK-AU-01 (app.au.snyk.io) (Snyk Code).