Github SCM Project Failing
Incident Report for Snyk
Resolved
Monitoring has shown no further issues, and affected services have returned to normal. Affected customers should initiate a retest of affected projects.
Snyk Incident Response is being stood down.
Posted Jun 25, 2024 - 01:05 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 25, 2024 - 01:02 UTC
Monitoring
The Snyk Incident Response remains in flight. The incident has now been mitigated and is under monitoring conditions.
Posted Jun 24, 2024 - 23:48 UTC
Update
The Snyk Incident response remains in flight. The Snyk Engineering team has identified the issue affecting the Github SCM project failures and is taking steps to mitigate it. The incident continues.
Posted Jun 24, 2024 - 22:33 UTC
Update
The Snyk Incident response remains in flight. Our Engineers have suspended recurring tests for open source and are continuing to investigate the observed failures with Github SCM projects. The incident continues.
Posted Jun 24, 2024 - 21:46 UTC
Update
The Snyk Incident response remains in flight. The Snyk Engineers continue to investigate the observed failures with Github SCM projects. The incident continues.
Posted Jun 24, 2024 - 20:34 UTC
Update
This incident affects operations on Github SCM projects. Customers may observe failures with importing projects. We also see manual and recurring tests, PR checks, and push events fail.
The Snyk Incident response remains in flight and is being investigated by our Engineering teams with priority.
Posted Jun 24, 2024 - 19:24 UTC
Update
Snyk Incident Response remains in flight. Our engineering team has confirmed that recurring tests for Github-based projects have been degraded. Manual retests are failing at this time. Our Snyk Engineering teams are determining if importing new Github projects fails. Investigation continues.
Posted Jun 24, 2024 - 18:26 UTC
Identified
Snyk Monitoring systems have identified errors affecting retests for SCM Projects. Customers will not see the expected results. The Snyk Incident Response Process has been enacted. Our Engineering teams are investigating the issue.
Posted Jun 24, 2024 - 17:56 UTC
This incident affected: SNYK-US-01 (app.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source), SNYK-US-02 (app.us.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source), SNYK-EU-01 (app.eu.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source), and SNYK-AU-01 (app.au.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source).