Snyk GitHub Integration Degradation

Incident Report for Snyk

Resolved

All operations have returned to a normal state after mitigation steps were taken by our engineers. The Incident Response has been stood down.
Posted Jul 30, 2025 - 21:17 UTC

Identified

Our engineers have identified and merged a fix, restoring scanning services. Restoration efforts are still ongoing.
Posted Jul 30, 2025 - 16:03 UTC

Investigating

Our Engineers have identified degradation affecting Open Source GitHub integrations. Affecting scanning, imports, PR Checks, Recurring Tests, and fix PRS.

This is currently impacting - Golang, .Net, NPM, Python, and Ruby, across our app.snykgov.io environment.

The Snyk Incident Response has been invoked, and our investigations are underway.
Posted Jul 30, 2025 - 14:33 UTC
This incident affected: SNYK-GOV-01 (app.snykgov.io) (Snyk Open Source).