Data Delay for Legacy Reporting
Incident Report for Snyk
Resolved
Snyk Engineers have implemented a fix, and data is now being successfully populated within the web UI and via the API. There is no further impact expected to customers services.
Posted Feb 07, 2024 - 15:19 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 07, 2024 - 15:05 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 07, 2024 - 13:33 UTC
Update
Snyk technical investigations remain ongoing.

The most recent data available is from 2023-02-07 at 22:00 UTC.
It has been identified that the /reporting/issues/latest endpoint is currently showing no data, due to the delays being experienced. The web UI also shows no data for this time period.

In order to retrieve data, a date prior to today’s date must be selected via the /reporting/issues/?from=[start_date]&to=[end_date] endpoint.

Further updates will follow.
Posted Feb 07, 2024 - 11:54 UTC
Update
Snyk Monitoring systems have identified significant delays affecting the data sourcing the Legacy Reporting UI and API. This only affects customers who have opted-in to the Legacy Reporting or who are using the V1 Reporting API. This does not affect the default Reporting offering.
This only affects the MT-US tenant (app.snyk.io). This does not affect the AU or EU tenants.

The Snyk Incident response process has been invoked.
Technical investigations are underway to establish the cause of the incident. Further updates will follow.
Posted Feb 07, 2024 - 10:31 UTC
Investigating
We are currently investigating this issue.
Posted Feb 07, 2024 - 10:30 UTC