Snyk Code PR Checks Degraded

Incident Report for Snyk

Resolved

Snyk Engineers have confirmed services are operating normally after mitigation steps were taken. No additional impact is expected. The Snyk Incident Response has been stood down.
Posted Apr 09, 2025 - 18:06 UTC

Monitoring

Our Engineers have identified the cause of the degraded performance and have taken action to mitigate the impact. No additional impact is observed and we are now under monitoring conditions.
Posted Apr 09, 2025 - 17:24 UTC

Update

Our Engineers have confirmed that customers may observe longer-than-normal complete times for CLI Code tests as well as Code PR checks. The Snyk Incident Response remains in flight as the investigation continues.
Posted Apr 09, 2025 - 16:59 UTC

Update

Our Engineers continue to investigate degraded performance observed with Snyk Code PR checks.
Posted Apr 09, 2025 - 16:43 UTC

Investigating

Our Engineers have identified that Snyk Code PR checks within the app.snyk.io environment are degraded.

Customers using the above environment may observe that Code PR checks are taking longer than normal to complete or fail.

The Snyk Incident Response has been invoked, and investigations are underway.
Posted Apr 09, 2025 - 14:57 UTC
This incident affected: SNYK-US-01 (app.snyk.io) (Snyk Code).