Degraded Performance SNYK-US-01

Incident Report for Snyk

Monitoring

Mitigation steps have been completed and are showing immediate improvements in success rate and latency, and are burning down the backlog. We will maintain a period of monitoring for continued stability.
Posted Jun 23, 2026 - 02:34 UTC

Update

Snyk Engineering is continuing to investigate the issue. Mitigation steps are progressing but will take some time to be fully effective.
Current scope of effect:

* Customers may notice increased latency across the Snyk UI platform, as well as API, CLI, SCM based projects and PR Checks. 
* Due to the increased latency, some tests may be observed to timeout and fail.
* There is currently no known observed impact to analytics and reporting.
This issue is not affecting other environments.
We will continue to work on mitigation efforts and provide updates as the issue progresses.
Posted Jun 23, 2026 - 00:52 UTC

Update

Snyk engineers are continuing their investigation. We have applied initial mitigation steps and are seeing signs of recovery, though some performance degradation persists. Our teams remain focused on a full resolution, and we will share another update shortly.
Posted Jun 22, 2026 - 23:06 UTC

Identified

Our engineering team is currently investigating reports of degraded performance in the SNYK-US-01 US Multi-tenant environment (app.snyk.io). We are actively working to isolate the cause and will provide updates as we the investigation progresses.
Posted Jun 22, 2026 - 22:21 UTC
This incident affects: SNYK-US-01 (app.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source).