Weekly Recurring Tests Degraded

Incident Report for Snyk

Update

The cause of the incorrectly quarantined projects has been resolved.
We are still working on restoring projects with a weekly retest schedule that were quarantined since the start of the issue, so that these projects can be scheduled for their next weekly recurring test.

Customers can also still trigger a manual test for affected projects via the project page in the UI

This may result in some projects which were correctly quarantined being re-activated - however these would then be quarantined again by the usual process.
Please note that quarantined tests do not affect the Active/Inactive status of the projects.
Posted Jul 10, 2025 - 07:50 UTC

Update

We are continuing to work on a fix for this issue: The cause of the incorrect quarantine has been resolved and we are working on restoring the recurring test cadence for affected projects
Posted Jul 10, 2025 - 00:06 UTC

Identified

Snyk engineers have identified an issue affecting recurring weekly project tests across all environments. Customers may observe that some tests are being incorrectly quarantined. The Snyk Incident Response has been activated, and a fix is being deployed.
Posted Jul 09, 2025 - 20:00 UTC
This incident affects: SNYK-US-01 (app.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source), SNYK-US-02 (app.us.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source), SNYK-EU-01 (app.eu.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source), SNYK-AU-01 (app.au.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source), and SNYK-GOV-01 (app.snykgov.io) (Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source).