Our Engineers have implemented a fix, and testing has verified that the incident has now been resolved.
The Snyk Incident Response has now been stood down.
Posted Jan 13, 2025 - 13:19 UTC
Investigating
Our engineers have identified authentication issues impacting users who haven't authenticated with Snyk and haven't set up an API URL.
Customers might notice that users configured to use app.us.snyk.io, who haven't specified an endpoint URL in their IDE or CLI while using OAuth2 authentication, encounter login problems indicating invalid credentials or occasional failures in redirecting to the correct cloud environment.
To workaround this issue, affected customers can specify the endpoint URL before authentication.
The Snyk Incident Response has been invoked and our Engineers are investigating.
Posted Jan 13, 2025 - 11:12 UTC
This incident affected: SNYK-US-02 (app.us.snyk.io) (Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source).