Scheduled maintenance - January 29th, 14:10 GMT
Incident Report for Snyk
Resolved
This incident has been resolved.
Posted Jan 29, 2023 - 20:04 UTC
Update
Maintenance was successful and is complete.
Posted Jan 29, 2023 - 20:04 UTC
Update
The maintenance is being monitored, services should now be in working order.
Posted Jan 29, 2023 - 14:30 UTC
Update
The maintenance is now undergoing, interruptions in service imminent for a short period of time.
Posted Jan 29, 2023 - 14:18 UTC
Update
Due to a required change in behaviour meant to improve customer experience, we will be scheduling a maintenance window on Sunday, January 29th at 14:10 GMT that will last approximately three hours.

During the maintenance, it is possible that some of the core Snyk services will temporarily experience outages for short periods of time.

What are we changing?
We’ll make changes to the unique definition of a project, making it so the path to the target file is considered part of it.

Why are we doing this and what is the improvement in behaviour?
You will be able to use the CLI’s --project-name flag to apply the same name to multiple projects that have different target files. Normally this action would result in a “Failed due to duplicate project” error message with a 409 status code, but now it will not.

How will it affect you?
If you have been experiencing “Failed due to duplicate project” error messages upon trying to re-import an existing project, that may have been because the path or name of your target file has changed. Projects answering to this criteria can now be updated using snyk monitor successfully.

It is now possible to hold multiple projects that are of the same name and properties and only differ by the name/location of the project’s target file.
Posted Jan 17, 2023 - 14:58 UTC
Investigating
We are currently investigating this issue.
Posted Jan 17, 2023 - 14:57 UTC