Bitbucket Cloud API Token Authentication Failures

Incident Report for Snyk

Resolved

Our Engineers have now deployed the fix to all Snyk environments, resolving the incident.

The Snyk Incident Response has now been stood down.
Posted Oct 03, 2025 - 14:10 UTC

Update

Snyk engineers have implemented a fix in the UI for SNYK-US-02, resolving the issue in that environment. Snyk plans to deploy this fix to the other environments tomorrow, October 3rd.
Posted Oct 02, 2025 - 16:42 UTC

Identified

While we have addressed the root issue, customers cannot configure Bitbucket Cloud integrations unless they have a pre-existing App Password.

Our teams are actively working towards restoring API Token integration functionality.
Posted Sep 30, 2025 - 13:06 UTC

Update

Although we have taken steps to resolve the underlying fault, customers will not be able to set up Bitbucket Cloud integrations unless they have a pre-existing App Password.

Our Engineers are working on a fix for this outstanding issue.
Posted Sep 29, 2025 - 08:15 UTC

Monitoring

Snyk engineers have completed mitigation steps in all environments and are currently monitoring the situation.
Posted Sep 27, 2025 - 13:30 UTC

Update

Snyk Engineers continue their mitigation efforts. Additional updates forthcoming.
Posted Sep 26, 2025 - 22:51 UTC

Identified

Customers who set up or migrated their Bitbucket Cloud token integrations to use API Token authentication instead of App Password authentication on or after September 23 at 3 p.m. UTC are experiencing failures when executing Git operations.

The Snyk Incident Response is currently underway. Snyk engineers have identified the issue and are taking steps to mitigate its impact.
Posted Sep 26, 2025 - 20:05 UTC
This incident affected: SNYK-US-01 (app.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source, Snyk Learn), SNYK-US-02 (app.us.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source, Snyk Learn), SNYK-EU-01 (app.eu.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source, Snyk Learn), SNYK-AU-01 (app.au.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source, Snyk Learn), and SNYK-GOV-01 (app.snykgov.io) (Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source).