[Upcoming Jan 16th 2024] DNS Change - possible breaking change if using IP allow list for traffic to Snyk
Incident Report for Snyk
Resolved
This incident has been resolved.
Posted Jan 18, 2024 - 10:48 UTC
Update
[Date change for deeproxy.snyk.io]

Snyk is planning to perform a DNS update on January 16th 2024, resulting in a change in IP addresses for 2 specific hostnames.
If your deployments, proxies, or any other configurations rely on IP whitelisting of the following IP address, action is required:

35.190.124.19 (deeproxy.snyk.io)
The allow listing should instead be applied for the *.snyk.io domains.

Impacted services, if using proxies or other network outbound control locking on IPs, includes:

code agent deployments
code CLI + IDE
34.74.193.29 (broker.snyk.io) was updated on January 8th similarly. If issues, allow listing should instead be applied for the *.snyk.io domains.

As a reminder, Snyk does not and will not support any static IP for any inbound to Snyk traffic. Please use domain allow list instead for *.snyk.io. Thank you.
Posted Jan 12, 2024 - 16:44 UTC
Update
[Date change for deeproxy.snyk.io]

Snyk is planning to perform a DNS update on January 15th 2024, resulting in a change in IP addresses for 2 specific hostnames.
If your deployments, proxies, or any other configurations rely on IP whitelisting of the following IP address, action is required:

35.190.124.19 (deeproxy.snyk.io)
The allow listing should instead be applied for the *.snyk.io domains.

Impacted services, if using proxies or other network outbound control locking on IPs, includes:

code agent deployments
code CLI + IDE
34.74.193.29 (broker.snyk.io) was updated on January 8th similarly. If issues, allow listing should instead be applied for the *.snyk.io domains.

As a reminder, Snyk does not and will not support any static IP for any inbound to Snyk traffic. Please use domain allow list instead for *.snyk.io. Thank you.
Posted Jan 10, 2024 - 12:42 UTC
Update
Snyk is planning to perform a DNS update on January 8th 2024, resulting in a change in IP addresses for 2 specific hostnames.
If your deployments, proxies, or any other configurations rely on IP whitelisting of the following IP addresses, action is required:
- 34.74.193.29 (broker.snyk.io)
- 35.190.124.19 (deeproxy.snyk.io)

The allow listing should instead be applied for the *.snyk.io domains.

Impacted services, if using proxies or other network outbound control locking on IPs, includes:
- broker deployments
- code agent deployments
- code CLI + IDE

As a reminder, Snyk does not and will not support any static IP for any inbound to Snyk traffic. Please use domain allow list instead for *.snyk.io. Thank you.
Posted Dec 21, 2023 - 11:10 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 21, 2023 - 11:06 UTC
Investigating
We are currently investigating this issue.
Posted Dec 21, 2023 - 11:06 UTC