Snyk CLI missing Required Permission
Incident Report for Snyk
Resolved
The deployed fix has been tested successfully.

Our Engineers are confident there should be no further issues.

The Snyk Incident Response has been stood down.
Posted Jun 27, 2024 - 13:18 UTC
Monitoring
Our Engineers have confirmed that the fix has been successfully deployed.

It is recommended that affected users upgrade their CLI version to 1.1292.1. Users of Snyk IDE plugins that experience these issues may need to update the underlying CLI as well.
Posted Jun 27, 2024 - 13:09 UTC
Identified
Our Engineers became aware of an issue which failed 'Snyk test' and 'Snyk monitor' runs for some users.

"Error: user does not have required permission on org"

A fix is currently being deployed.
Posted Jun 27, 2024 - 12:59 UTC
This incident affected: SNYK-US-01 (app.snyk.io) (Snyk Open Source), SNYK-US-02 (app.us.snyk.io) (Snyk Open Source), SNYK-EU-01 (app.eu.snyk.io) (Snyk Open Source), and SNYK-AU-01 (app.au.snyk.io) (Snyk Open Source).