Snyk Essentials (Group level) integration profiles are degraded

Incident Report for Snyk

Resolved

No further repeat of the issue was detected during scheduled re-scans. This incident is resolved.
Posted Apr 09, 2025 - 22:53 UTC

Monitoring

Our Engineers identified that a shutdown issue had caused all integrations to be incorrectly marked as failed after they had, in fact, been completed. A fix has been implemented, and we are monitoring to ensure its effectiveness.
Posted Apr 09, 2025 - 14:01 UTC

Update

We have verified that most workflows are completing normally, but we have detected an increase in load that may lead to some integrations being reported as failed. Scans are completing at a delayed rate of processing.
Investigation is ongoing as to the cause.
Posted Apr 09, 2025 - 02:34 UTC

Investigating

Snyk engineering has detected that some Group Level integration profiles- which are used for batch processes to update the Essentials Inventory- are degraded.
New connections cannot be created, and existing connections are shown as failing. Existing inventory assets are unaffected, but updates to asset inventory are delayed.
Organisation level SCM integrations (used for import, retest) are unaffected.
Snyk Engineering are investigating.
Posted Apr 09, 2025 - 01:57 UTC
This incident affected: SNYK-US-01 (app.snyk.io) (Snyk AppRisk).