Scanning failure for JAR files

Incident Report for Snyk

Resolved

Our Engineers have deployed an additional fix, resolving the issue in our app.snyk.io environment. All environments are now operating as expected.

The Snyk Incident Response has now been stood down.
Posted Mar 14, 2025 - 14:09 UTC

Identified

Our Engineers implemented a fix which has improved the error rate across our environments. However, our customers using our app.snyk.io environment may still experience issues when scanning JAR files.
Posted Mar 13, 2025 - 10:01 UTC

Update

Number of errors has dropped significantly since the mitigation was applied. We're continuing to monitor.
Posted Mar 08, 2025 - 15:17 UTC

Update

We've applied a mitigation to the issue, and will be monitoring it over the next few hours to ascertain its efficacy.
Posted Mar 08, 2025 - 11:52 UTC

Update

We have found a potential explanation for the failures, and are working to confirm it. We will share additional updates as we obtain more information.
Posted Mar 08, 2025 - 11:24 UTC

Update

We have found a potential explanation for the failures, and are working to confirm it. We will share additional updates as we obtain more information.
Posted Mar 08, 2025 - 11:23 UTC

Update

Failures are intermittent - users may experience tests on JAR files fail and succeed shortly after. We'll provide a full update as soon as we have additional details.
Posted Mar 08, 2025 - 10:16 UTC

Update

We're experiencing issues scanning JAR files in both Snyk Open Source and Snyk Container. The issue affects all environments.
Posted Mar 08, 2025 - 09:39 UTC

Investigating

We are currently investigating this issue.
Posted Mar 08, 2025 - 09:36 UTC
This incident affected: SNYK-US-01 (app.snyk.io) (Snyk Container, Snyk Open Source).