The Daily Tests From Mar 19, 2023 Is Degraded
Incident Report for Snyk
Resolved
This incident has been resolved.
Posted Mar 21, 2023 - 11:49 UTC
Update
We're nearing the completion of the automated test run and will provide an update once completed.
Posted Mar 21, 2023 - 10:40 UTC
Update
Projects that were scheduled to be tested yesterday (19th March) on a weekly cadence have completed testing.

We're in the process of an automated test run and anticipate the run to complete early to mid-morning UTC.
Posted Mar 20, 2023 - 18:09 UTC
Update
Automated Recurring tests scheduled for Mar 19, 2023 did not run as planned for http://app.snyk.io/ customers (US multi-tenant).

All testing systems are operational, manual retest, push-events, PR-checks are all unaffected. The impact is limited to automated tests.

Daily projects scheduled for the 19th will be tested as part of the usual automated run scheduled today (Mar 20, 2023).
Posted Mar 20, 2023 - 18:06 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2023 - 14:47 UTC
Update
What environment is impacted?
http://app.snyk.io/

What actually didn’t happen as it should have?
Recurring tests scheduled for Mar 19, 2023 did not run as planned for http://app.snyk.io/ customers.

What can a customer do in the meantime to get coverage?
Customers can manually retest their projects.

What we are doing about it?
The projects that should be tested on a daily frequency will be scheduled today (Mar 20, 2023).
The projects that should be tested and have a weekly frequency have been already tested.
Posted Mar 20, 2023 - 14:06 UTC
Update
-
Posted Mar 20, 2023 - 14:04 UTC
Update
We are actively running tests for projects that would've had a weekly run yesterday.
Posted Mar 20, 2023 - 12:42 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 20, 2023 - 09:58 UTC