Ruby Gems projects failing to be imported or tested.

Incident Report for Snyk

Resolved

This incident has been resolved.
Posted Apr 04, 2023 - 08:41 UTC

Update

Remediation Advice and Fix PRs for Ruby projects are now working as normal, in addition to Tests, PR Checks, and Imports.
Posted Apr 04, 2023 - 08:39 UTC

Update

A mitigation has been implemented and Tests, PR Checks, and Imports of Ruby projects for Snyk Open Source are now working as normal.
However, remediation advice and Fix PRs features remain unavailable for Snyk Open Source Ruby projects while we work to address the cause. We will provide an update by 2023-04-04 09:00 UTC.
Posted Apr 03, 2023 - 14:46 UTC

Update

We have identified the cause of Ruby errors and are working on a fix. These errors effect all testing of Ruby using Snyk, CLI and git integrations.
Posted Apr 03, 2023 - 13:19 UTC

Update

Investigating increased errors on Ruby git integration projects.
Posted Apr 03, 2023 - 12:53 UTC

Investigating

We are currently investigating this issue.
Posted Apr 03, 2023 - 12:51 UTC