Snyk UI Degraded

Incident Report for Snyk

Resolved

The fix has been successfully implemented, and we are no longer observing any degradation in the Snyk UI.

Our Incident Response has been stood down.
Posted Nov 28, 2025 - 14:59 UTC

Identified

We have identified the root cause of the incident and are currently deploying a fix.

A further update will be provided once the fix has been fully implemented.
Posted Nov 28, 2025 - 14:31 UTC

Update

During our investigation, we identified that the impact is limited to customers using our app.us.snyk.io environment.
Posted Nov 28, 2025 - 14:14 UTC

Investigating

Our Engineers have identified degradation affecting our User Interface.

Customers will notice that the Service Account web page is not listing current service accounts.

We can confirm that Service account tokens still exist and will function correctly. All Snyk tests and APIs continue to operate successfully.

The Snyk Incident Response has been invoked, and our investigations are progressing.
Posted Nov 28, 2025 - 13:35 UTC