Monitoring - The rate our platform processes request is back to normal. We’re currently monitoring the situation.
Mar 28, 2024 - 23:33 UTC
Investigating - The Snyk Engineering Team has identified a decrease in the rate of our platform processes requests. Customers may experience slow response times. The incident response has been invoked. Snyk technical teams are investigating the issue. Further updates to follow.
Mar 28, 2024 - 23:05 UTC
Investigating - Snyk Engineers are currently observing occasional drops in success rates in some of our APIs. The drops are observed at intermittent intervals, for extremely short durations.

Customers may see occasional failures/timeouts, for a brief duration when calling Snyk APIs.

The Snyk Incident response has been invoked, further updates will follow.

Mar 28, 2024 - 14:16 UTC
Platform Success Rate (US - Multi Tenant)
Fetching
Past Incidents
Mar 28, 2024

Unresolved incidents: Platform Degraded Performance, Occasional drops in success rates for Snyk APIs.

Mar 27, 2024

No incidents reported.

Mar 26, 2024
Resolved - This incident has been resolved.
Mar 26, 07:11 UTC
Monitoring - A fix has been implemented and we are monitoring the results.
Mar 26, 06:47 UTC
Update - We have identified that SCM imports will start, but will not show any projects found. This is affecting MT-US only. Snyk Incident Response is in flight
Mar 26, 06:33 UTC
Investigating - We are currently investigating this issue.
Mar 26, 06:31 UTC
Mar 25, 2024

No incidents reported.

Mar 24, 2024

No incidents reported.

Mar 23, 2024

No incidents reported.

Mar 22, 2024

No incidents reported.

Mar 21, 2024

No incidents reported.

Mar 20, 2024
Resolved - Snyk Technical Teams have completed their activity. Services are normalized. This incident is now resolved.
Mar 20, 19:32 UTC
Monitoring - Users connecting to app.synk.io experienced slow response times, which have now normalized. To ensure no further latency is observed, Snyk Technical Teams are taking mitigation steps that will result in all users connected to app.synk.io being logged out and needing to log back in. No additional downtime will be observed. This activity will take place within the next hour.
Mar 20, 17:46 UTC
Resolved - The Snyk Incident Response process has been stood down. Response times to app.snyk.io have normalized, and no impact is currently being experienced.
Mar 20, 16:50 UTC
Investigating - Snyk monitoring systems have identified degraded performance to app.snyk.io in the Multi-Tenant US (MT-US). The Snyk Incident Response process has been evoked. Technical Teams have been engaged. Initial triage is underway.
Mar 20, 16:24 UTC
Resolved - Snyk Engineers have deployed a fix which has restored Code analysis for multi-tenant EU (app.eu.snyk.io/) users.

Customers who experienced a failed analysis during the degradation period (12:05 UTC - 13:35 UTC) should manually re-trigger their scans.

No further impact is expected.

Mar 20, 13:43 UTC
Investigating - Snyk Monitoring tools have identified that Code analysis is currently degraded affecting multi-tenant EU (app.eu.snyk.io/) users.

This does not affect app.snyk.io or app.au.snyk.iok.

The Incident Response has been invoked and technical teams have commenced with initial investigations.

Mar 20, 13:25 UTC
Mar 19, 2024
Resolved - Snyk identified that Go imports with Full Source Code Analysis enabled were degraded between 22:30 UTC on the 14th of March and 21:35 UTC on the 17th of March.

Customers importing projects through the Snyk UI with go.mod files that didn't target the latest version of Go (1.22.1) may have observed a failure error when attempting imports.

Snyk Engineers have deployed a fix to restore functionality.

Mar 19, 11:59 UTC
Mar 18, 2024
Resolved - The Snyk Incident Response process has been stood down. All services have been restored, and no impact is currently being experienced.
Mar 18, 20:05 UTC
Monitoring - The Snyk Incident Response process remains in flight. Mitigation steps have been taken, services have stabilized, and are now under close monitoring.
Mar 18, 17:55 UTC
Investigating - Snyk Monitoring systems have identified that Gitlab PR checks are currently degraded. Other Gitlab features and PR checks from other sources are unaffected.

The Snyk Incident Response process has been invoked. Technical Teams have been engaged and initial triage is underway.

Mar 18, 16:45 UTC
Resolved - The Snyk Incident Response process has been stood down. All services have been restored, and no impact is currently being experienced.
Mar 18, 17:40 UTC
Monitoring - The Snyk Incident Response process remains in flight. Mitigation steps have been taken, services have stabilized, and are now under close monitoring.
Mar 18, 17:38 UTC
Investigating - Snyk monitoring tools have identified an intermittent outage affecting the Snyk platform in Multi-Tenant-US. Snyk Technical Teams are investigating. Additional updates will follow.
Mar 18, 17:25 UTC
Resolved - The Snyk Incident Response process has been stood down. All services have been restored, and no impact is currently being experienced.
Mar 18, 15:26 UTC
Monitoring - Snyk continues to observe delays which are affecting recurring tests. A small percentage of customers are experiencing missed daily test runs, impacting a small number of their projects. Any projects that miss their daily test runs, will complete the run the following day.

Snyk Engineers are aware of the situation and continue to take steps towards mitigating the delays.

Mar 1, 16:19 UTC
Identified - Snyk Technical Teams have observed delays affecting recurring tests. A small percentage of customers is experiencing for a small set of their projects to miss the daily test runs. They will complete the following day instead. Snyk Teams are aware of this situation and are taking steps to mitigate the delay.
Feb 28, 20:50 UTC
Resolved - Snyk Engineers have implemented a fix to fully restore automated tests.
Mar 18, 13:41 UTC
Monitoring - Snyk Engineers have identified that automated testing within the multi-tenant EU environment are being processed at a reduced rate.

A fix for this will be implemented by Monday the 18th of March, until then we expect some level of degradation to affect automated testing.

Mar 13, 17:16 UTC
Mar 17, 2024

No incidents reported.

Mar 16, 2024
Completed - The scheduled maintenance has been completed.
Mar 16, 15:35 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 16, 12:00 UTC
Scheduled - As previously announced, we have a planned maintenance on March 16th. This maintenance period is being reduced to 2 hours from the previously announced 12 hour window. The new maintenance window will be 12 pm UTC to 2 PM UTC.

Maintenance is currently scheduled to take place:

Saturday, March 16th, 12 pm UTC (8 AM ET, 1 PM GMT) to 2 pm UTC (10 AM ET, 3 PM GMT)

We will provide prompt updates on this page if the above date or time changes.

During this period, you may not be able to access Snyk’s services, including the CLI, API, UI and PR checks. For more information on this please check out our Maintenance Guide.

We understand that our services are important to your business operations and we have designed our maintenance process to minimize inconvenience to our customers. This maintenance window enables us to upgrade the Snyk platform to our new, more robust, and reliable service architecture, to better meet your business needs and to continue to scale in the future.

We will provide status updates during the maintenance window at status.snyk.io. If you have any questions or need any assistance, please don't hesitate to contact our support team.

Mar 13, 01:45 UTC
Mar 15, 2024
Resolved - The Snyk Incident Response process has been stood down. All services have been restored, and no impact is currently being experienced.
Mar 15, 18:56 UTC
Monitoring - The Snyk Incident Response process remains in flight. Snyk Technical Teams have taken action to mitigate the incident. Services are now restored and are under close monitoring conditions.
Mar 15, 18:42 UTC
Investigating - Snyk monitoring services have identified the Cloud Compliance Report as unresponsive. The Snyk Incident Response process has been evoked. Technical Teams have been engaged. Initial triage is underway.
Mar 15, 18:13 UTC
Mar 14, 2024

No incidents reported.