go.mod projects failures on Brokered Github and Github Enterprise

Incident Report for Snyk

Resolved

We have released a fix for the failures of Imports, Retests and PR Checks for Go Module projects. Our Engineers are no longer observing impact. The incident response process has been stood down.
Posted Feb 28, 2025 - 17:46 UTC

Identified

We have identified a fix for the failures of Imports, Retests and PR Checks for Go Module projects. A further update will be provided when we are confident that the fix can be released.
Posted Feb 28, 2025 - 10:50 UTC

Investigating

Snyk Engineers have detected failures with go.mod projects when integrated with GitHub/GitHub Enterprise via Broker.
This includes project failing to import, as well as failures of retests and PR checks.
We are currently investigating.
Posted Feb 28, 2025 - 07:08 UTC
This incident affected: SNYK-US-01 (app.snyk.io) (Snyk Open Source), SNYK-US-02 (app.us.snyk.io) (Snyk Open Source), SNYK-EU-01 (app.eu.snyk.io) (Snyk Open Source), and SNYK-AU-01 (app.au.snyk.io) (Snyk Open Source).